LeagueCSV

Versions

Installation

System Requirements

You need:

If you are using PHP >= 8.0, please use at least version 9.6.2 for compatibility.

Of note: It is recommended to use the latest stable version of the package in combination with the latest PHP version.

Composer

Csv is available on Packagist and can be installed using Composer:

$ composer require league/csv:^9.0

Going Solo

You can also use League\Csv without using Composer by downloading the library on Github.

The library is compatible with any PSR-4 compatible autoloader.

Also, League\Csv comes bundle with its own autoloader script autoload.php located in the root directory.

use League\Csv\Reader;
use League\Csv\Writer;

require '/path/to/league/csv/autoload.php';

//your script starts here

where path/to/league/csv represents the path where the library was extracted.