The League of Extraordinary Packages

Our Packages:

Presented by The League of Extraordinary Packages

Getting Started

The API

Upgrading Guide

This is the documentation for the unsupported version 7.0. Please consider upgrading your code to the latest stable version

Installation

System Requirements

You need PHP >= 5.4.0 or HHVM >= 3.2 and the mbstring extension to use League\Csv but the latest stable version of PHP/HHVM is recommended.

Composer

League\Csv is available on Packagist and can be installed using Composer:

$ composer require league/csv:^7.0

Going Solo

You can also use League\Csv without using Composer by downloading the library and using any other PSR-4 compatible autoloader.